Por razones que no vienen al caso, necesité instalar moodle en una mauina con Debian lenny

A continuación detallo los errores y las soluciones:

* Moodle 2.0.2 utilzia php versión 5.3, para solucionar este problema, utilice los repositorios http://www.dotdeb.org/ y agregue en su /etc/apt/sources.list la siguiente entrada;

deb http://php53.dotdeb.org lenny  all

Recuerde actualizar el sistema con aptitude update

* Moodle se queja de la codificación de la BD de mysql, ya que requiere que la BD utilizada por él sea en unicode y mysql en debian utilzia por defecto utf-8, para resolver esto, entre a la consola de administraciónd e mysql y ejecute el siguiente comando:

ALTER DATABASE moodle DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci;

Finalizados estos pasos, podrá continuar con la instalación de moodle sin mayores problemas.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Puedes usar las siguientes etiquetas HTML y atributos:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.